Eurocardsharing

Go Back   Eurocardsharing > Sharing receivers > Skystar 2 > Plugins

Plugins Discussion, emubox PRE BETA / CCcam with DVB-S under Windows at Skystar 2 forum; Originally Posted by 1234 hi , i try to run "run_debug" but get always error: [[email protected] bin]# ./run_debug ./CCcam.x86: /usr/lib/libstdc++.so.6: ...

Reply
 
LinkBack Thread Tools Display Modes
Old
  (#51)
kubi55
Junior Member
 
kubi55's Avatar
 
Offline
Posts: 20

Level: 3 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 55
Magic: 6 / 1499
Experience: 20%

Thanks: 3
Thanked 7 Times in 2 Posts
Join Date: Aug 2008
Age: 33
06-September-2008, 06:38

Quote:
Originally Posted by 1234 View Post
hi ,

i try to run "run_debug" but get always error:

[[email protected] bin]# ./run_debug
./CCcam.x86: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./emubox_interceptor.so)
./CCcam.x86: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by ./emubox_interceptor.so)


can someone help me?

best regards, 12345
getting the same problem as 1234, anyone with a solution to this?

ps. also using clarkconnect..
   
Reply With Quote
Old
  (#52)
silencer
Junior Member
 
silencer's Avatar
 
Offline
Posts: 8

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 18
Magic: 2 / 534
Experience: 73%

Thanks: 0
Thanked 12 Times in 4 Posts
Join Date: Jan 2008
06-September-2008, 13:12

The interceptor is build using newer versions of those library's. Try updating glibc and libstdc++. Ubuntu 8.04 and andLinux minimal releases have these newer versions pre installed, I will try to get a qemu image ready for the next release, so you do not have to mess met Linux :)
   
Reply With Quote
The Following 4 Users Say Thank You to silencer For This Useful Post:
chasthebiker (15-September-2008), kubi55 (07-September-2008), scarzam (06-September-2008), stendec (22-September-2008)
Sponsored Links
Old
  (#53)
scarzam
Junior Member
 
scarzam's Avatar
 
Offline
Posts: 27

Level: 3 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 73
Magic: 9 / 2153
Experience: 93%

Thanks: 13
Thanked 2 Times in 2 Posts
Join Date: Nov 2007
06-September-2008, 15:48

Hello d+ in 30w dont open.
   
Reply With Quote
Old
  (#54)
neztiti
Junior Member
 
neztiti's Avatar
 
Offline
Posts: 11

Level: 2 [♥ Bé-Yêu ♥]
Life: 0 / 28
Magic: 3 / 861
Experience: 12%

Thanks: 2
Thanked 0 Times in 0 Posts
Join Date: Jul 2007
06-September-2008, 19:25

Quote:
Originally Posted by silencer View Post
@leesbril

Windows:

Make sure the plugin is only in pip00, and do not modify the port in the configuration file (always 10000 for now).

C:\dvbdream\Plugins\pip00\emubox_plugin.dll
C:\dvbdream\Plugins\pip00\emubox_plugin.cfg

When the plugin is loaded it should always show up in the plugin menu. And when you open the PID Statistics on the Demultiplexer Statistics tab you should see a MDAPI - emubox_plugin filter on the pmt pid when you change channel.

Linux on virtual machine:

You need to use the run script, not run CCcam.x86 directly.

In the CCcam directory you should have these files:

Code:
CCcam.x86
emubox_interceptor.so
run_debug
run_background
Then run the script after making it executable:

Code:
cd cccamdirectory
chmod +x run_debug
./run_debug
You should see these messages (emubox_interceptor.so is loaded):

Code:
filter is gone, bye bye
09:15:12.607 CCcam: dvb api3 detected
09:15:12.607 CCcam: create 1 cam device(s)

hi dear silencer . it works fine here with alt-dvb and dvbdream and dvbviwer 3.9.4. go on man with your great plugin

Last edited by neztiti; 06-September-2008 at 19:51..
   
Reply With Quote
Old
  (#55)
kubi55
Junior Member
 
kubi55's Avatar
 
Offline
Posts: 20

Level: 3 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 55
Magic: 6 / 1499
Experience: 20%

Thanks: 3
Thanked 7 Times in 2 Posts
Join Date: Aug 2008
Age: 33
07-September-2008, 19:14

Quote:
Originally Posted by sattip View Post
hello.i have also tested but the problem was that it gave me a message
CHANNELCHANGE
CHANNELCHANGE
CHANNELCHANGE
CHANNELCHANGE
CHANNELCHANGE
no connection to capmt socket!!!!
CAPMT
session is gone, bye bye
i cannot understand why.plz help me
Silencer thank you for this great plugin.
but.. I'm now having the same problem as Sattip.. plz help..
   
Reply With Quote
Old
  (#56)
silencer
Junior Member
 
silencer's Avatar
 
Offline
Posts: 8

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 18
Magic: 2 / 534
Experience: 73%

Thanks: 0
Thanked 12 Times in 4 Posts
Join Date: Jan 2008
07-September-2008, 23:44

@kubi55 edit your CCcam.cfg and set dvb api detection on auto or version 3. You have it disabled or on an older version.
   
Reply With Quote
The Following User Says Thank You to silencer For This Useful Post:
Papi (11-September-2008)
Old
  (#57)
kubi55
Junior Member
 
kubi55's Avatar
 
Offline
Posts: 20

Level: 3 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 55
Magic: 6 / 1499
Experience: 20%

Thanks: 3
Thanked 7 Times in 2 Posts
Join Date: Aug 2008
Age: 33
08-September-2008, 00:54

Quote:
Originally Posted by silencer View Post
@kubi55 edit your CCcam.cfg and set dvb api detection on auto or version 3. You have it disabled or on an older version.
wow you;re wonderful :)

now it works!
   
Reply With Quote
Old
  (#58)
sakis
Junior Member
 
sakis's Avatar
 
Offline
Posts: 4

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 5
Magic: 1 / 175
Experience: 21%

Thanks: 0
Thanked 0 Times in 0 Posts
Join Date: Dec 2006
08-September-2008, 14:36

i had ubuntu vm running for hours with cccamd, without being connected with the emubox
and cccamd terminated

....
section is gone, bye bye
section is gone, bye bye
section is gone, bye bye
filter is gone, bye bye
session is gone, bye bye
01:48:45.364 CCcam: enigma interface: disconnected (0)
section is gone, bye bye
filter is gone, bye bye
section is gone, bye bye
filter is gone, bye bye
filter is gone, bye bye
./run_debug: line 1: 7178 Segmentation fault LD_PRELOAD='./emubox_interceptor.so' ./CCcam.x86 -d
[email protected]:~/Desktop/ccc/cccamd$
   
Reply With Quote
Old
  (#59)
pippomix
Junior Member
 
pippomix's Avatar
 
Offline
Posts: 20

Level: 3 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 55
Magic: 6 / 1577
Experience: 20%

Thanks: 1
Thanked 2 Times in 1 Post
Join Date: Feb 2008
11-September-2008, 01:08

Hi friends, i have install vmware, ubuntu 8.04 and i have installed the cccam 2.0.9... then i have put the emubox files into cccam folder and the 2 files into dvbdream/pip00 and dvb dream read correctly the plugin,...but the cccam on linux don-t communicate with the dvbdream, why? The window of cccam say this:

18:00:35.516 CCcam: starting CCcam 2.0.9 compiled on May 20 [email protected]:53:25
18:00:35.516 CCcam: ================================================== ====================
18:00:35.518 CCcam: online using nodeId f9f1dc3c9c30f8b6
filter is gone, bye bye
18:00:35.519 CCcam: dvb api3 detected
18:00:35.519 CCcam: create 1 cam device(s)
18:00:35.521 CCcam: added 545 keys from /var/keys/SoftCam.Key
18:00:35.522 CCcam: added 434 keys from /var/keys/AutoRoll.Key
18:00:35.522 CCcam: added 0 keys from /var/keys/constant.cw
18:00:35.523 CCcam: parsed 143 entries from /var/etc/CCcam.prio
18:00:35.524 CCcam: added 510 provider names from /var/etc/CCcam.providers
18:00:35.603 CCcam: added 4419 channel names from /var/etc/CCcam.channelinfo
18:00:35.603 CCcam: server started on port 12000


..and it don-t do nothing when i change channels on dvbdream..help me! Thankssss!
   
Reply With Quote
Old
  (#60)
reteps
Junior Member
 
reteps's Avatar
 
Offline
Posts: 5

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 8
Magic: 1 / 277
Experience: 34%

Thanks: 3
Thanked 0 Times in 0 Posts
Join Date: Nov 2006
11-September-2008, 18:10

Quote:
Originally Posted by pippomix View Post
Hi friends, i have install vmware, ubuntu 8.04 and i have installed the cccam 2.0.9... then i have put the emubox files into cccam folder and the 2 files into dvbdream/pip00 and dvb dream read correctly the plugin,...but the cccam on linux don-t communicate with the dvbdream, why? The window of cccam say this:

18:00:35.516 CCcam: starting CCcam 2.0.9 compiled on May 20 [email protected]:53:25
18:00:35.516 CCcam: ================================================== ====================
18:00:35.518 CCcam: online using nodeId f9f1dc3c9c30f8b6
filter is gone, bye bye
18:00:35.519 CCcam: dvb api3 detected
18:00:35.519 CCcam: create 1 cam device(s)
18:00:35.521 CCcam: added 545 keys from /var/keys/SoftCam.Key
18:00:35.522 CCcam: added 434 keys from /var/keys/AutoRoll.Key
18:00:35.522 CCcam: added 0 keys from /var/keys/constant.cw
18:00:35.523 CCcam: parsed 143 entries from /var/etc/CCcam.prio
18:00:35.524 CCcam: added 510 provider names from /var/etc/CCcam.providers
18:00:35.603 CCcam: added 4419 channel names from /var/etc/CCcam.channelinfo
18:00:35.603 CCcam: server started on port 12000


..and it don-t do nothing when i change channels on dvbdream..help me! Thankssss!

hi,
you have to edit the emubox_plugin.cfg insert the ip adress of ubuntu
(do IFCONFIG in the terminal of ubuntu and you will see it....)
and LEAVE the port number in emubox_plugin.cfg to 10000
so don't change portnumber.
good luck......
   
Reply With Quote
Reply

Bookmarks

Tags
beta, cccam, dvd-s, emubox, windows


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump



ECS on RSS ECS on Twitter ECS on Facebook ECS on Youtube
Follow us on:

Powered by vBulletin
Copyright 2002 - 2010, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
Dreambox