Eurocardsharing

Go Back   Eurocardsharing > Sharing receivers > Skystar 2 > Tutorials

Tutorials Discussion, How do I setup mythtv PC with DVB-S and use cccam? at Skystar 2 forum; or DVB-S2 for that matter. I realise that this is Skystar 2 forum but I believe the stuff is pretty ...

Reply
 
LinkBack Thread Tools Display Modes
How do I setup mythtv PC with DVB-S and use cccam?
Old
  (#1)
Juge
Junior Member
 
Juge's Avatar
 
Offline
Posts: 13

Level: 2 [♥ Bé-Yêu ♥]
Life: 0 / 34
Magic: 4 / 799
Experience: 38%

Thanks: 0
Thanked 2 Times in 2 Posts
Join Date: Feb 2010
How do I setup mythtv PC with DVB-S and use cccam? - 18-February-2010, 11:24

or DVB-S2 for that matter.

I realise that this is Skystar 2 forum but I believe the stuff is pretty much the same. I have now spent some time googleing and ended up here, not much wiser...

Anyway I have a Technotrend TT-S-1500 and a CI-Module. For some reason I was able to communicate with the CI with gnutv -cammenu (very sticky) in the beginning but then for some reason this stopped working. I tried the card combination under windows as well - no go. I got myself a new CI-Module and still no go. Maybe I have damaged my card in building in and out so maybe I give it another go later when I buy myself a TT-S-3200.

Meanwhile I have started speculating the possibility of using softcam and perhaps two DVB-S adapters. As far as I can see there is no way of getting two tuners to work in any other way as the CI-module is connected physically to tuner card and can not be used by the other one - so softcam seems to be the solution. This is howver, where I get lost.

Firstly hardware. I have at the moment conax card and a CI Module like this one: http://www.hm-sat-shop.de/ci-ca-modu...-ci-modul.html

I reckon that for softcam I need to have something like smargo and from the contradicting mails it might or might not work for me.

Then I suppose I need cccam ...and then what?

For creating a "virtual" decrypted video adapter that I can tune in mythtv I think I need sasc-ng but from one tutorial or another I read that I should get keys to some harddrive folder? Whereas this would be lucrative option as I would not have to have my card docked in smargo and I could use it in my actual digibox as well I am not sure whether a) I am able to extract some keys from my conax (possible at all) b) how often this needs to be done before codes expire or something like this.

Anyway what I believe/hope is that works is that sasc somehow communicates with cccam and gets the needed keys directly from my card that is docked in smargo.

Meanwhile I am, however, totally confused as I get thrown software names like newcs or radegast and so on from google.

What do I need in the end to accomplish my mission. What does the cccam do and do I really need sasc-ng in mythbuntu or is there another way. I think that sasc-ng can be used by any viewer in the end including kaffeine or mplayer or xine or whatever as it creates a virtual adapter, something like pvr can communicate with cccam or so and directly do the decrypting, is this correct.

So is it cccam and sasc-ng I should concentrate on, and how do I make these two to communicate with each other? Any really good easy examples, I am no newbie for linux but I am really a n00b when it comes down to satellites and decryption.
   
Reply With Quote
Old
  (#2)
cold007
Super Moderator
 
cold007's Avatar
 
Offline
Posts: 9,448

Level: 63 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 314 / 1570
Magic: 3149 / 49281
Experience: 82%

Thanks: 5,191
Thanked 4,423 Times in 2,537 Posts
Join Date: Apr 2007
Location: germany -unterfranken..
18-February-2010, 11:27

Quote:
Originally Posted by Juge View Post
or DVB-S2 for that matter.

.
seems you have put alot of time in the post---> id h8 to delete it-->
but...you forgot to

!!
...

unfortunatly...rule 5# broken,,with this quoted post..

its about time u visit the introduction section...

tutorials

cold007


dreambox 8000- box with icvs images!!

remember u SPAM = i BAN

activley hunting nline stealers...!

beware...of with whom you share!!




   
Reply With Quote
Sponsored Links
Old
  (#3)
tomvleeuwen
Junior Member
 
tomvleeuwen's Avatar
 
Offline
Posts: 24

Level: 3 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 65
Magic: 8 / 1532
Experience: 62%

Thanks: 8
Thanked 5 Times in 4 Posts
Join Date: Jan 2010
Location: Netherlands
20-February-2010, 17:59

I didn't read your whole post (sorry), but I also tried to get Mythtv running with cccam (DVB-C in my case, budget card)
The only way I managed to get it working was with the sasc-ng version in the contrib dir in VDR-SC plugin:
http://85.17.209.13:6100/sc

Hope it helps.

Tom

PS: That version of sasc-ng can connect directly to CCcam:
Add the following line to cardclient.conf:
cccam2:ip:port:emm/caid/mask:user:pass

so it looks like:
cccam2:127.0.0.1:12000:1/0123/ffff:myusername:mypassword

Last edited by tomvleeuwen; 20-February-2010 at 18:01.. Reason: PS
   
Reply With Quote
Old
  (#4)
Juge
Junior Member
 
Juge's Avatar
 
Offline
Posts: 13

Level: 2 [♥ Bé-Yêu ♥]
Life: 0 / 34
Magic: 4 / 799
Experience: 38%

Thanks: 0
Thanked 2 Times in 2 Posts
Join Date: Feb 2010
27-February-2010, 20:33

I am not sure I know how to download the sasc - is it with subversion or how?

I now got the smargo and downloaded the cccam 2.1.3
I modified the cccam.cfg and when I give cccam.x86 -dv I get:
9:30:46.761 CCcam: ================================================== ====================
19:30:46.761 CCcam: starting CCcam 2.1.3 compiled on Nov 14 [email protected]:48:18
19:30:46.761 CCcam: ================================================== ====================
19:30:46.761 CCcam: online using nodeId 7aa0d47ab9c990aa
19:30:46.762 CCcam: dvb api3 detected
19:30:46.762 CCcam: create 1 cam device(s)
19:30:47.732 CCcam: conax card found
19:30:47.918 CCcam: card added to broker with caid b00
19:30:47.933 CCcam: readKeyfile: cannot open /var/keys/SoftCam.Key or not found
19:30:47.933 CCcam: readKeyfile: cannot open /var/keys/AutoRoll.Key or not found
19:30:47.933 CCcam: static cw not found or bad
19:30:47.933 CCcam: parsed 0 entries from /var/etc/CCcam.prio
19:30:47.933 CCcam: readProviderfile: cannot open /var/etc/CCcam.providers or not found
19:30:47.933 CCcam: readChannelList: cannot open /var/etc/CCcam.channelinfo or not found
19:30:47.934 CCcam: server started on port 12000
19:30:47.935 CCcam: no working cam devices, no need to start pmthandler

it seems that I get the conax card and I am not sure about the missing keys and stuff. I read from some other example message like that and the guy wrote that his stuff is running so maybe the messages do not mean a thing.

I however, do not get anything if I type in the machines IP and port 16001 - is this normal?
   
Reply With Quote
Old
  (#5)
tomvleeuwen
Junior Member
 
tomvleeuwen's Avatar
 
Offline
Posts: 24

Level: 3 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 65
Magic: 8 / 1532
Experience: 62%

Thanks: 8
Thanked 5 Times in 4 Posts
Join Date: Jan 2010
Location: Netherlands
28-February-2010, 01:13

Quote:
Originally Posted by Juge View Post
I am not sure I know how to download the sasc - is it with subversion or how?
Just click on bz2 or gz on top of the page. Otherwise, you could install mercurial and use
hg clone http://85.17.209.13:6100/sc

I have little experience with CCcam, but at my site I can connect to port 16001 for HTTP and port 16000 for telnet.


P4 Ubuntu 10.04 cardserver with Smargo and CCcam 2.1.2
Core 2 Quad Ubuntu 11.04 with two budget-DVB-C and MythTV
Dreambox 500 C (Clone)
Dreambox 800 with cable tuner (Clone)
   
Reply With Quote
Old
  (#6)
Juge
Junior Member
 
Juge's Avatar
 
Offline
Posts: 13

Level: 2 [♥ Bé-Yêu ♥]
Life: 0 / 34
Magic: 4 / 799
Experience: 38%

Thanks: 0
Thanked 2 Times in 2 Posts
Join Date: Feb 2010
28-February-2010, 09:51

Thanks, I think I got sasc-ng semi-succesfully compiled, the module insertion works and stuff. Followed the instructions from here http://dolot.kipdola.com/wiki/Install_SASC-NG

Unfortunately in chapter 4.1 it says among other things mv sc_files/* /etc/camfiles/
I do not appear to have any directory called sc_files here...

Then as for cccam - I doubt it works since I get no reply with telnet nor anything else
I suppose it isn't running...

I put cardclient.conf then under /etc/camfiles/sc_files
cccam2:127.0.0.1:12000:1/b00/ffff:<user>:<passwd>

shouldn't it be 16000 here as port or so? b00 should be my cardid as reported by cccam?about ffff I have no idea - copied it from you...
   
Reply With Quote
Old
  (#7)
boknoy_ph
Super Moderator
 
boknoy_ph's Avatar
 
Offline
Posts: 2,391

Level: 39 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 96 / 964
Magic: 797 / 26604
Experience: 56%

Thanks: 140
Thanked 843 Times in 599 Posts
Join Date: Aug 2008
Location: C:\Recyle Bin
28-February-2010, 09:55

AFAIK, CCcam does not read conax cards. you need newcs to read the card, then throw it towards CCcam. and from there, you connect sasc-ng.

another headache to throw in your mix.


HP-Compaq DC5000 MT 1.5GB RAM
Debian Squeeze with Smargos
CCcam 2.1.3
   
Reply With Quote
Old
  (#8)
Juge
Junior Member
 
Juge's Avatar
 
Offline
Posts: 13

Level: 2 [♥ Bé-Yêu ♥]
Life: 0 / 34
Magic: 4 / 799
Experience: 38%

Thanks: 0
Thanked 2 Times in 2 Posts
Join Date: Feb 2010
28-February-2010, 10:22

I thought I read it from somewhere that it works directly but maybe I am mistaken. newcs - hmm, of course there is no harm trying I guess but how do I get started?

(28-February-2010 17:22)
I think I somehow got the newcs to recognize the card but that's about that cccam does not work any better with or without newcs.

Here is the log from newcs:
# cat /tmp/newcs.log
[ 17:06:02 ] [ Box detect ] Box type 1 (General Boxtype - Generic)
[ 17:06:02 ] [ Config ] Irdeto EMM mode 0 SET on reader Smargo
[ 17:06:02 ] [ Config ] Option <blockc0> for device 0 (Smargo) not present, defaulting to NO
[ 17:06:02 ] [ Config ] Value in <ipk> for device 0 (Smargo) is INVALID, skipping...
[ 17:06:02 ] [ Config ] Value in <ucpk> for device 0 (Smargo) is INVALID, skipping...
[ 17:06:02 ] [ Config ] Pincode for device 0 (Smargo): 0000
[ 17:06:02 ] [ SID ] Adding SID 0000 on Reader 0 (Smargo) - SO is: 0 [Allow]
[ 17:06:02 ] [ SID ] Adding SID 0001 on Reader 0 (Smargo) - SO is: 0 [Allow]
[ 17:06:02 ] [ SID ] Adding SID 0002 on Reader 0 (Smargo) - SO is: 0 [Allow]
[ 17:06:02 ] [ SID ] Adding SID 0000 on Reader 0 (Smargo) - SO is: 0 [Deny]
[ 17:06:02 ] [ SID ] Adding SID 0001 on Reader 0 (Smargo) - SO is: 0 [Deny]
[ 17:06:02 ] [ SID ] Adding SID 0002 on Reader 0 (Smargo) - SO is: 0 [Deny]
[ 17:06:02 ] [ Config ] /dev/ttyUSB0 ECM priority: round
[ 17:06:02 ] [ Newcamd ] Server name : newcs
[ 17:06:02 ] [ Newcamd ] Des key : 0102030405060708091011121314
[ 17:06:02 ] [ Newcamd ] User 2: user, Pass: passwd, Host 192.168.178.22, Port: 12000, Au: On, Spider allowed: No, Sidoverride: No, level: 1
[ 17:06:02 ] [ httpd ] httpd-user: user, password: passwd, accesslevel: admin
[ 17:06:02 ] [ EMM Cache ] Initialising dynamic Cache
[ 17:06:02 ] [ ECM Cache ] Initialising dynamic Cache
[ 17:06:02 ] Calibrating delay loops
[ 17:06:02 ] usleep(5) takes: 0 s 5 us
[ 17:06:02 ] usleep(10) takes: 0 s 11 us
[ 17:06:02 ] usleep(100) takes: 0 s 100 us
[ 17:06:02 ] usleep(500) takes: 0 s 4425 us
[ 17:06:02 ] Allocation memory for 200 regular users
[ 17:06:02 ] [ Loader ] Starting Telnet on port 1001
[ 17:06:02 ] bind: error! 13: Permission denied
[ 17:06:02 ] [ SockSrv ] Stopping port 1001
[ 17:06:02 ] [ SockSrv ] Server thread started
[ 17:06:02 ] [ Loader ] Started HTTP-server on port: 8080
[ 17:06:02 ] [ Loader ] Reader type 2 on node /dev/ttyUSB0
[ 17:06:02 ] [ Phoenix ] Opening device /dev/ttyUSB0
[ 17:06:02 ] [ Phoenix ] Setting Parity to: NONE
[ 17:06:02 ] [ Phoenix ] Setting 2 Stop bits on node /dev/ttyUSB0
[ 17:06:02 ] [ Phoenix ] Setting Baud to standard 9600
[ 17:06:02 ] [ Phoenix ] Normal RESET on node /dev/ttyUSB0
[ 17:06:04 ] [ Serial ] Read on fd 6 (len=7 timeout=5300ms)
[ 17:06:04 ] [ ATR ] T=0 1etu=104.17us Guardtime:12etu WWT:9600etu
[ 17:06:04 ] [ ATR ] Historical bytes: 0 B 0 0
[ 17:06:04 ] [ Loader ] Init Conax card
[ 17:06:04 ] [ Phoenix ] Setting Parity to: EVEN
[ 17:06:04 ] [ Phoenix ] Setting 2 Stop bits on node /dev/ttyUSB0
[ 17:06:04 ] [ Phoenix ] Setting Baud to standard 9600
[ 17:06:04 ] [ Serial ] Write on fd 6 (len=5)
[ 17:06:04 ] [ Serial ] Read on fd 6 (len=5 timeout=1500ms)
[ 17:06:06 ] [ Serial ] Read timeout (1 of 5)
[ 17:06:06 ] [ Phoenix ] Failed to read echo (res=1, size=5)
[ 17:06:06 ] [ Loader ] Card 0B00 on port /dev/ttyUSB0 failed
[ 17:06:06 ] [ Card queue /dev/ttyUSB0 ] Starting...
[ 17:06:06 ] [ Loader ] Starting Newcamd Server on port 15050
[ 17:06:06 ] [ Newcamd ] Newcamd thread Server started on port 15050
[ 17:06:06 ] [ Loader ] Starting Radegast Server on port 10001
[ 17:06:06 ] [ SockSrv ] Server thread started
[ 17:06:43 ] [ httpd ] User user logged in..

At the moment I only have following in CCcam.cfg
N: 127.0.0.1 12000 user passwd 01 02 03 04 05 06 07 08 09 10 11 12 13 14
################################################## ####################
# Other config settings #
################################################## ####################
# server shall listen on this port pro incoming connections
# default port is 12000, disable server with parm -s or set port 0
#
#SERVER LISTEN PORT : 12000

# server can give some info about server and client connections
# and cardinfo using telnet or webbrowser.
#
# Switch on/off access to info
# default is yes
#
ALLOW TELNETINFO: yes
ALLOW WEBINFO: yes

# Show extended client info when showing client list
# default is yes
#
#SHOW EXTENEDED CLIENT INFO : no

# The webinfo service can be protected with a username and password.
# This is switched off by default
#
#WEBINFO USERNAME : <username>
#WEBINFO PASSWORD : <password>

# The telnetinfo service can be protected with a username and password.
# This is switched off by default
#
#TELNETINFO USERNAME : <username>
#TELNETINFO PASSWORD : <password>

# default port for telnet is 16000
# default port for web is 16001
# supported commands:
# info
# activeclients
# clients
# servers
# shares
# providers
# entitlements
# example use:
# echo servers | telnet localhost 16000
# go with your browser to http://ip_CCcam_server:16001
#
TELNETINFO LISTEN PORT : 16000
WEBINFO LISTEN PORT : 16001
DEBUG : yes
#SERIAL READER : /dev/ttyUSB0 smartreader+

beats me there is no reply nor in telnet or http. For newcs I get the webpage...

Last edited by Juge; 28-February-2010 at 18:22.. Reason: Automerged Doublepost
   
Reply With Quote
Old
  (#9)
tomvleeuwen
Junior Member
 
tomvleeuwen's Avatar
 
Offline
Posts: 24

Level: 3 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 65
Magic: 8 / 1532
Experience: 62%

Thanks: 8
Thanked 5 Times in 4 Posts
Join Date: Jan 2010
Location: Netherlands
28-February-2010, 20:55

Why do you want to use CCcam in the first place? sasc-ng can connect to NewCS directly.

All you need is one line in cardclient.conf (you don't need any other file from sc_files)

You can find an example file in the examples dir of the previous mentioned VDR-SC folder (not in the subdir contrib/sasc-ng, but in the root of the repository)


P4 Ubuntu 10.04 cardserver with Smargo and CCcam 2.1.2
Core 2 Quad Ubuntu 11.04 with two budget-DVB-C and MythTV
Dreambox 500 C (Clone)
Dreambox 800 with cable tuner (Clone)
   
Reply With Quote
Old
  (#10)
Juge
Junior Member
 
Juge's Avatar
 
Offline
Posts: 13

Level: 2 [♥ Bé-Yêu ♥]
Life: 0 / 34
Magic: 4 / 799
Experience: 38%

Thanks: 0
Thanked 2 Times in 2 Posts
Join Date: Feb 2010
28-February-2010, 22:37

Yes, I realized that too. Anyway I am making slow progress. I got the card somehow recognized it is also showing on the web interface with entitlements.

The telnet is not starting for some reason whatsoever but I don't know if that's important or whether there would be more info there.

I have sasc-ng up and running and it seems to be talking with newcs. At least I can scan and szap with the new adapter but the picture is missing. Also mythtv does not like to show me any of the crypted channels.
   
Reply With Quote
Reply

Bookmarks

Tags
cccam?, dvb-s, mythtv, setup


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump



ECS on RSS ECS on Twitter ECS on Facebook ECS on Youtube
Follow us on:

Powered by vBulletin
Copyright 2002 - 2010, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
Dreambox