Eurocardsharing

Go Back   Eurocardsharing > Sharing receivers > VDR and Kaffeine

VDR and Kaffeine Discussion, HOWTO: Getting the HVR-4000 and NOVA-HD cards working in Linux using multiproto at Sharing receivers forum; Can anyone tell me where am going wrong, Everything seems to install fine but nothing works. AM using Nova-HD--S2 card. ...

Reply
 
LinkBack Thread Tools Display Modes
Old
  (#31)
cooler
Member
 
cooler's Avatar
 
Offline
Posts: 38

Level: 4 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 98
Magic: 12 / 2846
Experience: 94%

Thanks: 7
Thanked 13 Times in 7 Posts
Join Date: Jan 2007
18-January-2009, 07:34

Can anyone tell me where am going wrong, Everything seems to install fine but nothing works. AM using Nova-HD--S2 card.

Thanks



dmesg | grep dvb
[ 78.430589] cx88/2: cx2388x dvb driver version 0.0.6 loaded
[ 78.430611] cx88/2: registering cx8802 driver, type: dvb access: shared
[ 121.188619] cx24116_firmware_ondemand: Waiting for firmware upload (dvb-fe-cx24116.fw)...

dmesg | grep cx
[ 76.551754] cx88/2: cx2388x MPEG-TS Driver Manager version 0.0.6 loaded
[ 76.554355] cx88[0]: subsystem: 0070:6906, board: Hauppauge WinTV-HVR4000(Lite) DVB-S/S2 [card=69,autodetected]
[ 76.554372] cx88[0]: TV tuner type -1, Radio tuner type -1
[ 76.607724] cx88/0: cx2388x v4l2 driver version 0.0.6 loaded
[ 77.454327] cx88[0]: hauppauge eeprom: model=69100
[ 77.484952] input: cx88 IR (Hauppauge WinTV-HVR400 as /devices/pci0000:00/0000:00:1e.0/0000:01:00.2/input/input4
[ 77.515848] cx88[0]/2: cx2388x 8802 Driver Manager
[ 77.515925] cx88[0]/2: found at 0000:01:00.2, rev: 5, irq: 9, latency: 64, mmio: 0xed000000
[ 77.516133] cx88[0]/0: found at 0000:01:00.0, rev: 5, irq: 9, latency: 64, mmio: 0xeb000000
[ 77.516321] cx88[0]/0: registered device video0 [v4l2]
[ 77.516428] cx88[0]/0: registered device vbi0
[ 78.430589] cx88/2: cx2388x dvb driver version 0.0.6 loaded
[ 78.430611] cx88/2: registering cx8802 driver, type: dvb access: shared
[ 78.430629] cx88[0]/2: subsystem: 0070:6906, board: Hauppauge WinTV-HVR4000(Lite) DVB-S/S2 [card=69]
[ 78.430644] cx88[0]/2: cx2388x based DVB/ATSC card
[ 79.970226] DVB: registering new adapter (cx88[0])
[ 121.188619] cx24116_firmware_ondemand: Waiting for firmware upload (dvb-fe-cx24116.fw)...
[ 121.231136] cx24116_firmware_ondemand: Waiting for firmware upload(2)...
[ 126.525687] cx24116_load_firmware: FW version 1.22.82.0
[ 126.525789] cx24116_firmware_ondemand: Firmware upload complete

# scan /usr/share/doc/dvb-utils/examples/scan/dvb-s/Astra-19.2 -x0 -t1 >channels.conf
scanning /usr/share/doc/dvb-utils/examples/scan/dvb-s/Astra-19.2
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
main:2247: FATAL: failed to open '/dev/dvb/adapter0/frontend0': 16 Device or resource busy
   
Reply With Quote
Old
  (#32)
cooler
Member
 
cooler's Avatar
 
Offline
Posts: 38

Level: 4 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 98
Magic: 12 / 2846
Experience: 94%

Thanks: 7
Thanked 13 Times in 7 Posts
Join Date: Jan 2007
19-January-2009, 08:09

Ok found the problem to that, since I couldn't run vdr I tried to installed mythtv and that caused this conflict problem, so I uninstall it, and decided to give VDR another try.

If you get conflicting issue this command will tel you whats conflicting.

lsof /dev/dvb/adapter0/frontend0

I know the driver is loaded fine and I can run Kaffeine fine.

Last edited by cooler; 19-January-2009 at 08:42..
   
Reply With Quote
Sponsored Links
nova dvb-s2 hd and ubuntu 8.10 not working
Old
  (#33)
micro77
Junior Member
 
micro77's Avatar
 
Offline
Posts: 5

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 8
Magic: 1 / 233
Experience: 34%

Thanks: 12
Thanked 0 Times in 0 Posts
Join Date: Aug 2007
nova dvb-s2 hd and ubuntu 8.10 not working - 12-February-2009, 22:00

hi
i read your tuto.
i tried but my dvb card nova hd not working...

Code:
 dmesg | grep dvb
[   16.129749] cx88/2: cx2388x dvb driver version 0.0.6 loaded
[   16.129754] cx88/2: registering cx8802 driver, type: dvb access: shared
[   23.145035] cx88[0]/2: dvb_register failed (err = -22)
[   23.382399] cx88/2: cx2388x dvb driver version 0.0.6 loaded
[   23.382404] cx88/2: registering cx8802 driver, type: dvb access: shared
[   29.784914] cx88[0]/2: dvb_register failed (err = -22)
Code:
lspci
01:08.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
01:08.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)
01:08.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
01:08.4 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [IR Port] (rev 05)
what can i do ?
best regards
micro
   
Reply With Quote
Old
  (#34)
yrref
Junior Member
 
yrref's Avatar
 
Offline
Posts: 1

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 0
Magic: 0 / 0
Experience: 0%

Thanks: 0
Thanked 0 Times in 0 Posts
Join Date: Mar 2009
08-March-2009, 01:45

Great Howto!

Thanks.

But now there are new drivers released and the old link does not match.

http://www.wintvcd.co.uk/drivers/88x...27056_WHQL.zip

And how must the following line be changed to get the fw:

dd if=hcw88bda.sys of=dvb-fe-cx24116.fw skip=75504 bs=1 count=32501

Thank You
   
Reply With Quote
Old
  (#35)
mckinley
Junior Member
 
mckinley's Avatar
 
Offline
Posts: 3

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 2
Magic: 1 / 61
Experience: 10%

Thanks: 0
Thanked 0 Times in 0 Posts
Join Date: Mar 2009
21-March-2009, 16:53

Hi all,

I have a problem with HVR-400 installation. After driver install I did a reboot, but nothing change.

With a dmesg | grep dvb, no response and with a lspci -k I obtain this:

Localhost ~ # lspci -k
00:00.0 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge (rev 03)
Kernel driver in use: agpgart-via
00:00.1 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:0f.0 IDE interface: VIA Technologies, Inc. VX800 Serial ATA and EIDE Controller
Kernel driver in use: VIA_IDE
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
Kernel driver in use: uhci_hcd
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
Kernel driver in use: uhci_hcd
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
Kernel driver in use: uhci_hcd
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
Kernel driver in use: ehci_hcd
00:11.0 ISA bridge: VIA Technologies, Inc. CX700/VX700 PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. CX700/VX700 Internal Module Bus
00:13.0 PCI bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. CX700/VX700 PCI to PCI Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. CX700/VX700 [S3 UniChrome Pro] (rev 03)
02:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)
Kernel driver in use: HDA Intel
03:08.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 8d)
Kernel driver in use: via-rhine
03:09.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev 80)
Kernel driver in use: ohci1394
Kernel modules: ohci1394
03:0f.0 Multimedia video controller: Conexant Device 8000 (rev 05)
03:0f.1 Multimedia controller: Conexant Device 8011 (rev 05)
03:0f.2 Multimedia controller: Conexant Device 8002 (rev 05)
03:0f.4 Multimedia controller: Conexant Device 8004 (rev 05)

Seems that system doesn't recognize the board or it is unable to match drivers with devices. I put the firmware in /lib/firmware and in /usr/lib/hotplug/firmware/

I'm using gentoo with kernel 2.6.27-r8

Thank you in advance for any help
   
Reply With Quote
Old
  (#36)
shalafi
ECS Master
 
shalafi's Avatar
 
Offline
Posts: 412

Level: 18 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 446
Magic: 137 / 12292
Experience: 87%

Thanks: 127
Thanked 492 Times in 131 Posts
Join Date: Jul 2007
21-March-2009, 17:50

I think that the modules weren't installed. Can you check dmesg or the bootlog for output concerning the cx88 based modules?

And what does lcpci -v tell you about the conexant devices?

//Shalafi


-=[ Ubuntu Linux 9.04 | VDR 1.7.9 | HVR-4000 | eHD | Wavefield T55]=-
   
Reply With Quote
Old
  (#37)
mckinley
Junior Member
 
mckinley's Avatar
 
Offline
Posts: 3

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 2
Magic: 1 / 61
Experience: 10%

Thanks: 0
Thanked 0 Times in 0 Posts
Join Date: Mar 2009
21-March-2009, 19:23

Thank you shalafi for the answer

Noyhing in dmesg about cx88 and nothing in /var/log/messages.

Here it is my lspci -v:

00:00.0 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge (rev 03)
Subsystem: VIA Technologies, Inc. Device aa09
Flags: bus master, medium devsel, latency 8
Memory at c0000000 (32-bit, prefetchable) [size=256M]
Capabilities: [80] AGP version 3.5
Capabilities: [50] Power Management version 2
Kernel driver in use: agpgart-via

00:00.1 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
Flags: bus master, medium devsel, latency 0

00:00.2 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
Flags: bus master, medium devsel, latency 0

00:00.3 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
Flags: bus master, medium devsel, latency 0

00:00.4 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
Flags: bus master, medium devsel, latency 0

00:00.7 Host bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge
Flags: bus master, medium devsel, latency 0

00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, medium devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 0000e000-0000efff
Memory behind bridge: dd000000-deffffff
Prefetchable memory behind bridge: a0000000-bfffffff
Capabilities: [70] Power Management version 2

00:0f.0 IDE interface: VIA Technologies, Inc. VX800 Serial ATA and EIDE Controller (prog-if 8a [Master SecP PriP])
Subsystem: VIA Technologies, Inc. Device aa09
Flags: bus master, medium devsel, latency 32
[virtual] Memory at 000001f0 (32-bit, non-prefetchable) [size=8]
[virtual] Memory at 000003f0 (type 3, non-prefetchable) [size=1]
[virtual] Memory at 00000170 (32-bit, non-prefetchable) [size=8]
[virtual] Memory at 00000370 (type 3, non-prefetchable) [size=1]
I/O ports at fc00 [size=16]
Capabilities: [b0] Power Management version 2
Kernel driver in use: VIA_IDE

00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. Device aa09
Flags: bus master, medium devsel, latency 32, IRQ 20
I/O ports at f800 [size=32]
Capabilities: [80] Power Management version 2
Kernel driver in use: uhci_hcd

00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. Device aa09
Flags: bus master, medium devsel, latency 32, IRQ 22
I/O ports at f400 [size=32]
Capabilities: [80] Power Management version 2
Kernel driver in use: uhci_hcd

00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. Device aa09
Flags: bus master, medium devsel, latency 32, IRQ 21
I/O ports at f000 [size=32]
Capabilities: [80] Power Management version 2
Kernel driver in use: uhci_hcd

00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90) (prog-if 20 [EHCI])
Subsystem: VIA Technologies, Inc. Device aa09
Flags: bus master, medium devsel, latency 32, IRQ 23
Memory at dffff000 (32-bit, non-prefetchable) [size=256]
Capabilities: [80] Power Management version 2
Capabilities: [88] Debug port: BAR=1 offset=00a0
Kernel driver in use: ehci_hcd

00:11.0 ISA bridge: VIA Technologies, Inc. CX700/VX700 PCI to ISA Bridge
Subsystem: VIA Technologies, Inc. Device aa09
Flags: medium devsel
Capabilities: [c0] Power Management version 2

00:11.7 Host bridge: VIA Technologies, Inc. CX700/VX700 Internal Module Bus
Subsystem: VIA Technologies, Inc. CX700/VX700 Internal Module Bus
Flags: medium devsel
Capabilities: [58] HyperTransport: Interrupt Discovery and Configuration

00:13.0 PCI bridge: VIA Technologies, Inc. CX700/VX700 Host Bridge (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
I/O behind bridge: 0000d000-0000dfff
Memory behind bridge: dfe00000-dfefffff
Prefetchable memory behind bridge: 00000000dfd00000-00000000dfdfffff

00:13.1 PCI bridge: VIA Technologies, Inc. CX700/VX700 PCI to PCI Bridge (prog-if 01 [Subtractive decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
I/O behind bridge: 0000c000-0000cfff
Memory behind bridge: dfc00000-dfcfffff
Prefetchable memory behind bridge: 00000000dfb00000-00000000dfbfffff

01:00.0 VGA compatible controller: VIA Technologies, Inc. CX700/VX700 [S3 UniChrome Pro] (rev 03) (prog-if 00 [VGA controller])
Subsystem: VIA Technologies, Inc. CX700/VX700 [S3 UniChrome Pro]
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 16
Memory at a0000000 (32-bit, prefetchable) [size=512M]
Memory at dd000000 (32-bit, non-prefetchable) [size=16M]
[virtual] Expansion ROM at de000000 [disabled] [size=64K]
Capabilities: [60] Power Management version 2
Capabilities: [70] AGP version 3.0

02:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)
Subsystem: VIA Technologies, Inc. Device aa09
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at dfefc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel <?>
Kernel driver in use: HDA Intel

03:08.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 8d)
Subsystem: VIA Technologies, Inc. Device 0107
Flags: bus master, stepping, medium devsel, latency 32, IRQ 18
I/O ports at cc00 [size=256]
Memory at dfcff000 (32-bit, non-prefetchable) [size=256]
Capabilities: [44] Power Management version 2
Kernel driver in use: via-rhine

03:09.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev 80) (prog-if 10 [OHCI])
Subsystem: VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller
Flags: bus master, stepping, medium devsel, latency 32, IRQ 19
Memory at dfcfe000 (32-bit, non-prefetchable) [size=2K]
I/O ports at c800 [size=128]
Capabilities: [50] Power Management version 2
Kernel driver in use: ohci1394
Kernel modules: ohci1394

03:0f.0 Multimedia video controller: Conexant Device 8000 (rev 05)
Subsystem: Hauppauge computer works Inc. Device 6102
Flags: fast devsel, IRQ 5
Memory at 40000000 (32-bit, non-prefetchable) [disabled] [size=16M]
Capabilities: [44] Vital Product Data <?>
Capabilities: [4c] Power Management version 2

03:0f.1 Multimedia controller: Conexant Device 8011 (rev 05)
Subsystem: Hauppauge computer works Inc. Device 6102
Flags: fast devsel, IRQ 5
Memory at 41000000 (32-bit, non-prefetchable) [disabled] [size=16M]
Capabilities: [4c] Power Management version 2

03:0f.2 Multimedia controller: Conexant Device 8002 (rev 05)
Subsystem: Hauppauge computer works Inc. Device 6102
Flags: fast devsel, IRQ 5
Memory at 42000000 (32-bit, non-prefetchable) [disabled] [size=16M]
Capabilities: [4c] Power Management version 2

03:0f.4 Multimedia controller: Conexant Device 8004 (rev 05)
Subsystem: Hauppauge computer works Inc. Device 6102
Flags: fast devsel, IRQ 5
Memory at 43000000 (32-bit, non-prefetchable) [disabled] [size=16M]
Capabilities: [4c] Power Management version 2

I really don't know what to do.
   
Reply With Quote
Old
  (#38)
shalafi
ECS Master
 
shalafi's Avatar
 
Offline
Posts: 412

Level: 18 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 446
Magic: 137 / 12292
Experience: 87%

Thanks: 127
Thanked 492 Times in 131 Posts
Join Date: Jul 2007
21-March-2009, 19:33

You might want to modprobe the modules manually. Use the following:

cx88_dvb,cx8802,cx8800,cx88xx,cx24116

If you can't manually modprobe it, then you haven't installed the drivers correctly.

//Shalafi


-=[ Ubuntu Linux 9.04 | VDR 1.7.9 | HVR-4000 | eHD | Wavefield T55]=-
   
Reply With Quote
Old
  (#39)
mckinley
Junior Member
 
mckinley's Avatar
 
Offline
Posts: 3

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 2
Magic: 1 / 61
Experience: 10%

Thanks: 0
Thanked 0 Times in 0 Posts
Join Date: Mar 2009
21-March-2009, 19:47

I installed manually cx8802,cx8800,cx88xx

For cx24116 I obtained: FATAL: Module cx24116 not found.
For cx88_dvb I obtained: FATAL: Error inserting cx88_dvb (/lib/modules/2.6.27-gentoo-r8/kernel/drivers/media/video/cx88/cx88-dvb.ko): No such device

After a dmesg | grep cx88:

cx88/2: cx2388x MPEG-TS Driver Manager version 0.0.6 loaded
cx88/0: cx2388x v4l2 driver version 0.0.6 loaded
cx88/2: cx2388x dvb driver version 0.0.6 loaded
cx88/2: registering cx8802 driver, type: dvb access: shared

What a strange thing, and when I compiled the drivers no error was found.

Thank you anyway
   
Reply With Quote
Old
  (#40)
shalafi
ECS Master
 
shalafi's Avatar
 
Offline
Posts: 412

Level: 18 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 446
Magic: 137 / 12292
Experience: 87%

Thanks: 127
Thanked 492 Times in 131 Posts
Join Date: Jul 2007
21-March-2009, 20:15

Did you do a make install and a depmod? Because it's mandatory. You might want to do it again.

Sometimes some distro's have symbolic links to folders, remove the symbolic link. You might want clean the drivers/media/video and all subflders.

//Shalafi


-=[ Ubuntu Linux 9.04 | VDR 1.7.9 | HVR-4000 | eHD | Wavefield T55]=-
   
Reply With Quote
Reply

Bookmarks

Tags
cards, howto:, hvr-4000, linux, nova-hd, working


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump



ECS on RSS ECS on Twitter ECS on Facebook ECS on Youtube
Follow us on:

Powered by vBulletin
Copyright 2002 - 2010, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
Dreambox