Eurocardsharing

Go Back   Eurocardsharing > Sharing receivers > VDR and Kaffeine

VDR and Kaffeine Discussion, sasc-ng not decrypting at Sharing receivers forum; I have compiled and installed sasc-ng (version 442eee2f550d, as found with hg identify http://85.17.209.13:6100/sc ) on an Ubuntu 10.10 (x86_64, ...

Reply
 
LinkBack Thread Tools Display Modes
sasc-ng not decrypting
Old
  (#1)
cazal7mavu
Junior Member
 
cazal7mavu's Avatar
 
Offline
Posts: 2

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 0
Magic: 0 / 19
Experience: 2%

Thanks: 0
Thanked 0 Times in 0 Posts
Join Date: Feb 2008
Location: Lige
sasc-ng not decrypting - 06-October-2011, 14:46

I have compiled and installed sasc-ng (version 442eee2f550d, as found with hg identify http://85.17.209.13:6100/sc) on an Ubuntu 10.10 (x86_64, kernel 2.6.35-30-generic).

After loading the module (with modprobe dvbloopback), I start sasc-ng in the foregound, like this:
Code:
sasc-ng -j 0:1 --cam-budget --sid-allpid --sid-nocache --cam-dir /etc/camfiles -d 0xff0000c0
Most of the time this will start, but sometimes it will dump core and exit. Once it does start, I start (on another terminal)
Code:
mplayer -dvbin card=2 dvb://"Das Erste"
which will work (it's an FTA channel).

Code:
mplayer -dvbin card=2 dvb://"NGC"
will show the exact same debug output. It seems as if sasc-ng doesn't 'see' it's an encrypted channel.

At that time, sasc-ng does not respond to INTR (not by Ctrl-C, not by sending it with killall). I can successfully change the channel back to "Das Erste". After it exits (with killall -9 sasc-ng), I try again.

And again, and again. And all of a sudden, it works! Now, I can change channels (the ones for which I pay are decoded) and sasc-ng responds to Ctrl-C as well.

But the next start - nothing.

I'm sure all my configfiles and the cardserver are OK. This all used to work (with sasc-ng 61975953edd0 or even older).

My Question(s):
  1. Does anyone else see this behaviour?
  2. Could the BKL (big kernel lock) patch which was applied have anything to do with it?
  3. Who has this (reliably) working on Ubuntu 11.04?


MythTV (Ubuntu, SkyStar2, sasc-ng) and dBox2 (Neutrino, newcamd)
   
Reply With Quote
Old
  (#2)
phel
Junior Member
 
phel's Avatar
 
Offline
Posts: 2

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 0
Magic: 0 / 19
Experience: 2%

Thanks: 0
Thanked 4 Times in 2 Posts
Join Date: Mar 2008
07-October-2011, 11:07

I'm seeing the same. I use a recent kernel (3.0.4) patched to work with sasc-ng and have been recompiling the dvbloopback-module several times over the last few months to incorporate support for recent kernels. However freshly compiled versions of sasc-ng have not been working for quite some time. I'm currently running a binary built from the latest source on 2011-03-25. Looking at the commits I assume the problem is with one of the more recent (< 2 months old) commits, but I haven't had the time to investigate further.
   
Reply With Quote
Sponsored Links
Yep, works on Ubuntu 11.04
Old
  (#3)
yacss
Junior Member
 
yacss's Avatar
 
Offline
Posts: 11

Level: 2 [♥ Bé-Yêu ♥]
Life: 0 / 28
Magic: 3 / 544
Experience: 12%

Thanks: 1
Thanked 1 Time in 1 Post
Join Date: Jul 2011
Yep, works on Ubuntu 11.04 - 07-October-2011, 15:35

Quote:
Originally Posted by cazal7mavu View Post
My Question(s):
  1. Does anyone else see this behaviour?
  2. Could the BKL (big kernel lock) patch which was applied have anything to do with it?
  3. Who has this (reliably) working on Ubuntu 11.04?
I've got two systems with ubuntu 11.04 / sasc-ng / oscam / mythtv, both work reliably.
  • Stock kernel from ubuntu 11.04 (32 bit)
  • Oscam #5781
  • Sasc-NG parent: 567:8e75b4904680 tip, patched for 2.6.38 compatibility; should not be necessary with current hg, but haven't tried that.

I don't think the BKL Patches are at fault here: a problem at that point would also affect free channels and not just the encrypted ones.

There are two points where my systems diverge from posted solutions: I removed all systems except for cardclient from sasc-ng and I use out-of-kernel dvb drivers. One system has the TBS driver tree and the other uses current dvb development drivers. Both trees have been patched for the BKL issue.
   
Reply With Quote
Old
  (#4)
yacss
Junior Member
 
yacss's Avatar
 
Offline
Posts: 11

Level: 2 [♥ Bé-Yêu ♥]
Life: 0 / 28
Magic: 3 / 544
Experience: 12%

Thanks: 1
Thanked 1 Time in 1 Post
Join Date: Jul 2011
10-October-2011, 12:37

Just tried current sasc-ng (SC version 1.0.0pre-HG-442eee2f550d+): no joy, sasc-ng process keeps segfaulting. Switched back to my old config (SC version 1.0.0pre-HG-8e75b4904680+ ), patched for 2.6.38 compatibility. Stable again.
   
Reply With Quote
Reply

Bookmarks

Tags
core dump, decrypting, initialization, sasc-ng, ubuntu 10.10


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump



ECS on RSS ECS on Twitter ECS on Facebook ECS on Youtube
Follow us on:

Powered by vBulletin
Copyright 2002 - 2010, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
Dreambox