Eurocardsharing

Go Back   Eurocardsharing > Sharing receivers > VDR and Kaffeine

VDR and Kaffeine Discussion, still need CCcam with vdr-sc version 0.9.1? at Sharing receivers forum; Hi everyone, a newbie question. From the documentation in vdr-sc 0.9.1, I see that they "Added CCcam cardclient.". And the ...

Reply
 
LinkBack Thread Tools Display Modes
still need CCcam with vdr-sc version 0.9.1?
Old
  (#1)
fooo
Junior Member
 
fooo's Avatar
 
Offline
Posts: 4

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 5
Magic: 1 / 146
Experience: 21%

Thanks: 1
Thanked 0 Times in 0 Posts
Join Date: Dec 2008
still need CCcam with vdr-sc version 0.9.1? - 26-April-2009, 21:23

Hi everyone,
a newbie question. From the documentation in vdr-sc 0.9.1, I see that they "Added CCcam cardclient.". And the content of cardclient.conf configuration file of vdr-sc is very similar to the CCcam.cfg of CCcam.

I've seen some related thread but it's not clear to me if I can get rid of the CCcam standalone client.

Thanks for any help.
   
Reply With Quote
Old
  (#2)
shalafi
ECS Master
 
shalafi's Avatar
 
Offline
Posts: 412

Level: 18 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 446
Magic: 137 / 13875
Experience: 87%

Thanks: 127
Thanked 492 Times in 131 Posts
Join Date: Jul 2007
27-April-2009, 00:19

I don't know which version of vdr-sc you're using, but the cardclient.conf hasn't changed at all in the official vdr-sc repository. I just fetched the latest trunk and it still contains the following in cardclient.conf:

Code:
# ccam client
#
# NOTE: hostname will be ignore. CCcam must be runnning on the local machine
# 'socket' is the name of the camd socket file. For multiple cards add %d
# into the string. This will be replaced with the number 0-3.
# e.g. /var/emu/chroot%d/tmp/camd.socket
cccam:hostname:port:emm/caid/mask:socket
As it's stated, it still requires a running CCcam instance. And it still requires the ca.c preload configuration.

//Shalafi


-=[ Ubuntu Linux 9.04 | VDR 1.7.9 | HVR-4000 | eHD | Wavefield T55]=-
   
Reply With Quote
Sponsored Links
Old
  (#3)
fooo
Junior Member
 
fooo's Avatar
 
Offline
Posts: 4

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 5
Magic: 1 / 146
Experience: 21%

Thanks: 1
Thanked 0 Times in 0 Posts
Join Date: Dec 2008
27-April-2009, 01:38

Quote:
Originally Posted by shalafi View Post
As it's stated, it still requires a running CCcam instance. And it still requires the ca.c preload configuration.

//Shalafi
Yeah, I see. But in the source there's:

systems/cardclient/cccam.c

And in the HISTORY file:

22.12.2008: Version 0.9.1
[...]
- Added CCcam cardclient.

On the other hand, also README.CCcam talks about ca.c, LD_PRELOAD and so on. So I was wondering what it means "added a CCcam cardclient".

fooo
   
Reply With Quote
Old
  (#4)
shalafi
ECS Master
 
shalafi's Avatar
 
Offline
Posts: 412

Level: 18 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 446
Magic: 137 / 13875
Experience: 87%

Thanks: 127
Thanked 492 Times in 131 Posts
Join Date: Jul 2007
27-April-2009, 08:39

That part has been part of the current CCcam implemenation since the trunk edition of vdr-sc. I guess they just updated the HISTORY file, the implementation is still the same.

So you can't use a direct connection to CCcam. Only the PRELOAD is working as a CCcam client.

//Shalafi


-=[ Ubuntu Linux 9.04 | VDR 1.7.9 | HVR-4000 | eHD | Wavefield T55]=-
   
Reply With Quote
Reply

Bookmarks

Tags
0.9.1?, cccam, vdr-sc, version


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump



ECS on RSS ECS on Twitter ECS on Facebook ECS on Youtube
Follow us on:

Powered by vBulletin
Copyright 2002 - 2010, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
Dreambox