Eurocardsharing

Go Back   Eurocardsharing > Sharing receivers > VDR and Kaffeine

VDR and Kaffeine Discussion, vdr-plugin-sc installation issues at Sharing receivers forum; Hi, I have previously had the sc plugin installed and running but after uninstalling it I'm unable to reinstall (or ...

Reply
 
LinkBack Thread Tools Display Modes
vdr-plugin-sc installation issues
Old
  (#1)
ant_thomas
Member
 
ant_thomas's Avatar
 
Offline
Posts: 31

Level: 4 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 82
Magic: 10 / 1915
Experience: 31%

Thanks: 1
Thanked 8 Times in 6 Posts
Join Date: Mar 2010
vdr-plugin-sc installation issues - 04-January-2011, 21:03

Hi,

I have previously had the sc plugin installed and running but after uninstalling it I'm unable to reinstall (or compile).

I've tried these .debs that I've got hold of...

vdr-plugin-sc_0.9.x-hg2_i386_1.7.15.deb
vdr-plugin-sc_0.9.x-hg2_i386_1.7.16_yavdr_0.3.deb
vdr-plugin-sc_0.9.x~hg2_i386.deb
vdr-plugin-sc_0.9.x-hg2_i386.deb

all now give the same error...

Code:
Selecting previously deselected package vdr-plugin-sc.
(Reading database ... 93205 files and directories currently installed.)
Unpacking vdr-plugin-sc (from vdr-plugin-sc_0.9.x-hg2_i386_1.7.16_yavdr_0.3.deb) ...
[: 160: sc: unexpected operator
[: 160: false: unexpected operator
[: 160: false: unexpected operator
Setting up vdr-plugin-sc (0.9.x~hg2) ...
Adding 'vdr' to group 'dialout'
Any one got any ideas? Is this because VDR is now a newer version?

I'm running VDR version - 1.7.16-12yavdr7
   
Reply With Quote
The Following User Says Thank You to ant_thomas For This Useful Post:
gianluca68 (12-January-2011)
Old
  (#2)
frenchkiwi
Junior Member
 
frenchkiwi's Avatar
 
Offline
Posts: 3

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 2
Magic: 1 / 71
Experience: 10%

Thanks: 2
Thanked 0 Times in 0 Posts
Join Date: Feb 2009
Age: 40
06-January-2011, 23:06

Please read the forum..

http://www.eurocardsharing.com/f273/...-plugin-237840

It's th same solution for all version of vdr
   
Reply With Quote
Sponsored Links
Old
  (#3)
ant_thomas
Member
 
ant_thomas's Avatar
 
Offline
Posts: 31

Level: 4 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 82
Magic: 10 / 1915
Experience: 31%

Thanks: 1
Thanked 8 Times in 6 Posts
Join Date: Mar 2010
08-January-2011, 19:42

Quote:
Originally Posted by frenchkiwi View Post
Please read the forum..

http://www.eurocardsharing.com/f273/...-plugin-237840

It's th same solution for all version of vdr

Where on that post does it mention my problem?
   
Reply With Quote
Old
  (#4)
TheTom
Junior Member
 
TheTom's Avatar
 
Offline
Posts: 17

Level: 2 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 46
Magic: 5 / 963
Experience: 86%

Thanks: 1
Thanked 7 Times in 5 Posts
Join Date: Jan 2011
23-January-2011, 22:22

I think I can help.. I created the initial deb source ;D

The Packages was made for Debian... not for Ubuntu... I can fix them, but the more easy way is, that you use the prebuild pkg from this ppa:

https://launchpad.net/~mirak-mirak

They are for yaVDR stable, testing and unstable

Just use the right ppa and install the sc package.

Greetings,
TheTom
   
Reply With Quote
The Following 2 Users Say Thank You to TheTom For This Useful Post:
gianluca68 (26-February-2011), svwandi (19-February-2011)
Old
  (#5)
ranXeron
Junior Member
 
ranXeron's Avatar
 
Offline
Posts: 3

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 2
Magic: 1 / 57
Experience: 10%

Thanks: 2
Thanked 0 Times in 0 Posts
Join Date: Dec 2010
26-January-2011, 11:33

Quote:
Originally Posted by TheTom View Post
I think I can help.. I created the initial deb source ;D

The Packages was made for Debian... not for Ubuntu... I can fix them, but the more easy way is, that you use the prebuild pkg from this ppa:

https://launchpad.net/~mirak-mirak

They are for yaVDR stable, testing and unstable

Just use the right ppa and install the sc package.

Greetings,
TheTom
Hi Tom -

thanks for the link.

Id installed the yavdr-0.3.0a.iso offered at yavdr.org, so I assume I do have to choose miraks stable-vdr build?

Thanks again
   
Reply With Quote
Old
  (#6)
TheTom
Junior Member
 
TheTom's Avatar
 
Offline
Posts: 17

Level: 2 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 46
Magic: 5 / 963
Experience: 86%

Thanks: 1
Thanked 7 Times in 5 Posts
Join Date: Jan 2011
29-January-2011, 08:52

it depend with, what you use.. when you not chanced the yavdr-ppa then you have the stable ppa.

normally the file /etc/apt/sources.list.d/yavdr.list lists the follow content:

Code:
deb http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu lucid main
deb http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu lucid main
deb http://ppa.launchpad.net/yavdr/stable-yavdr/ubuntu lucid main
and the follow command should not show you more than
Code:
grep -R vdr /etc/apt/sources.list*
/etc/apt/sources.list.d/mirak-mirak-stable-vdr-lucid.list:deb http://ppa.launchpad.net/mirak-mirak/stable-vdr/ubuntu lucid main
/etc/apt/sources.list.d/mirak-mirak-stable-vdr-lucid.list:deb-src http://ppa.launchpad.net/mirak-mirak/stable-vdr/ubuntu lucid main
/etc/apt/sources.list.d/yavdr.list.save:deb http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu lucid main
/etc/apt/sources.list.d/yavdr.list.save:deb http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu lucid main
/etc/apt/sources.list.d/yavdr.list.save:deb http://ppa.launchpad.net/yavdr/stable-yavdr/ubuntu lucid main
/etc/apt/sources.list.d/mirak-mirak-stable-vdr-lucid.list.save:deb http://ppa.launchpad.net/mirak-mirak/stable-vdr/ubuntu lucid main
/etc/apt/sources.list.d/yavdr.list:deb http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu lucid main
/etc/apt/sources.list.d/yavdr.list:deb http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu lucid main
/etc/apt/sources.list.d/yavdr.list:deb http://ppa.launchpad.net/yavdr/stable-yavdr/ubuntu lucid main
you can also post your output - when your are not sure


Don't forget the Thanks Button
Search for Kabel Deutschland Friends
   
Reply With Quote
The Following User Says Thank You to TheTom For This Useful Post:
ranXeron (31-January-2011)
Old
  (#7)
ranXeron
Junior Member
 
ranXeron's Avatar
 
Offline
Posts: 3

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 2
Magic: 1 / 57
Experience: 10%

Thanks: 2
Thanked 0 Times in 0 Posts
Join Date: Dec 2010
31-January-2011, 00:11

Quote:
Originally Posted by TheTom View Post
it depend with, what you use.. when you not chanced the yavdr-ppa then you have the stable ppa.
Yep got the stable ppa - so finally how do I install? With "sudo apt-get install vdr-plugin-opensc" ? Sorry but Im a real noob when it comes to linux ...
   
Reply With Quote
Old
  (#8)
TheTom
Junior Member
 
TheTom's Avatar
 
Offline
Posts: 17

Level: 2 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 46
Magic: 5 / 963
Experience: 86%

Thanks: 1
Thanked 7 Times in 5 Posts
Join Date: Jan 2011
31-January-2011, 08:49

yes right... but I prefer aptitude as package manager (in newer ubuntu version you have to install it extra) because it mark packages which got installed as a dependency of a other package.. so when you not need anymore package xy you remove it and all other packages which are not needed get removed too.


Don't forget the Thanks Button
Search for Kabel Deutschland Friends
   
Reply With Quote
Old
  (#9)
tantefrie
Junior Member
 
tantefrie's Avatar
 
Offline
Posts: 3

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 2
Magic: 1 / 56
Experience: 10%

Thanks: 3
Thanked 2 Times in 1 Post
Join Date: Jan 2011
31-January-2011, 16:55

Quote:
Originally Posted by TheTom View Post
I think I can help.. I created the initial deb source ;D

The Packages was made for Debian... not for Ubuntu... I can fix them, but the more easy way is, that you use the prebuild pkg from this ppa:

https://launchpad.net/~mirak-mirak

They are for yaVDR stable, testing and unstable

Just use the right ppa and install the sc package.

Greetings,
TheTom
Hi TheTom

I tried to install your vdr-plugin-opensc.
But apt cant find the right vdr-abi.

I use the e-tobi Repositorys and Debian squeeze.
Is there any chance i can get it to work with my vdr version 1.7.16 ?

Thanks alot
   
Reply With Quote
Old
  (#10)
TheTom
Junior Member
 
TheTom's Avatar
 
Offline
Posts: 17

Level: 2 [♥ Bé-Yêu ♥♥ Bé-Yêu ♥]
Life: 0 / 46
Magic: 5 / 963
Experience: 86%

Thanks: 1
Thanked 7 Times in 5 Posts
Join Date: Jan 2011
31-January-2011, 18:26

when u use vdr packages from a other source, you have to recompile the vdr-plugin-opensc package.

load the source vdr-plugin-opensc_1.0.0+20101127-ppa1.tar.gz & vdr-plugin-opensc_1.0.0+20101127-ppa1.dsc (or newer) from

https://launchpad.net/~mirak-mirak/+...-vdr/+packages

and than extract it with: dpkg-source -x vdr-plugin-opensc_1.0.0+20101127-ppa1.dsc

go in the new directory and install build-depedenys (read from debian/control file) and run dpkg-buildpackage

then you get the package compiled for your vdr version which you find a directory back (cd ..) and install it with dpkg -i NAME.deb

(sorry, its a quick howto.. I miss currently a bit of time... when u run in trouble i can get you better instructions...


Don't forget the Thanks Button
Search for Kabel Deutschland Friends
   
Reply With Quote
The Following User Says Thank You to TheTom For This Useful Post:
tantefrie (31-January-2011)
Reply

Bookmarks

Tags
installation, issues, vdr-plugin-sc


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump



ECS on RSS ECS on Twitter ECS on Facebook ECS on Youtube
Follow us on:

Powered by vBulletin
Copyright 2002 - 2010, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
Dreambox