Go Back   Eurocardsharing > Sharing receivers > DreamBox > Chat

Chat Discussion, DM500+ RS232 problem at DreamBox forum; Hi, This is my first post with one conclusion! I have 3 DM500+ in my office, and I am sure ...

LinkBack Thread Tools Display Modes
DM500+ RS232 problem
vjeko's Avatar
Posts: 3

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 2
Magic: 1 / 69
Experience: 10%

Thanks: 1
Thanked 1 Time in 1 Post
Join Date: Jan 2008
DM500+ RS232 problem - 26-February-2008, 11:21


This is my first post with one conclusion!
I have 3 DM500+ in my office, and I am sure that serial port on those linux machines doesn't work.
I am trying to get work SC8IN1 through RS232 on DM500+, but it is impossible due unknown reasons. Same reader works on WinXP machine with NewCS 1.50, tested with one card inside. I have copied working newcs.xml from windows machine to linux machine - DM500+ (I am win fun), and just edit node tags from COM1 to /dev/tts/0. Of course, chmod 755 is executed (I think that 644 is enough for config files, but I am not sure, because I am pretty new in dreambox and linux world).
Yes, I have tried with different Gemini images - 4.10 and 4.30.
Yes, Don't open serial in Expert setup is checked - ticked.
Yes, RS232 works with DreamUp for flashing purposes in combination with LAN.
Yes, I have read a lot of posts, but there is no answer anywhere.
Yes, I have tryed NewCS with internal card reader and it works fine.
Yes, I have tryed with Cccam 2.07, and also it works with internal card reader, but with Phoenix or SC8IN1 it doesn't work. Of course, I have edited cccam.cfg for writedelay and other lines needed for external RS232 card reader.

I think that new DMs have some hardware problems with handshaking lines on RS232, but I need oppinion of CS experts. Some of those lines are needed for Carddetect in NewCS, I think - not sure.
OR, there is some procces in Gemini 4.10/4.30 which opens RS232 through boot, and I cannot use that device (port) because it is allready opened???

So, please help!

My DMs S/N beggins with 7B07, so pretty new (produced on 07.11.2007, or maybe I am wrong?)

Thanks in advance!
Reply With Quote
Junior Member
skygate's Avatar
Posts: 4

Level: 1 [♥ Bé-Yêu ♥]
Life: 0 / 5
Magic: 1 / 137
Experience: 21%

Thanks: 0
Thanked 0 Times in 0 Posts
Join Date: Mar 2008
23-April-2008, 12:14

yes - you possibly have some DM500 clones which have been reported with serial I/O problems.

unfortunately - the serial poer will work finw with deramup but when connected to a phoenix interface - as might be needed for running newcs - it will fail in sending a reset to the card.

As far as I know - there is no published 'fix' for this - I personaly did not pull out the test equipement to have a closer look as to why / where the actual problem is.

The solution is to use the DM's with this problem as 'clients' - they will not need a serial port to be used as a client - you simply need to connect to the internent via the RJ45 ethernet connector.

Have a look at the LNB connections - I bet they are not 'in-line' with the RS-232 serial socket on the back of the DM. The clones with the serial problem did not have the ALPs tuner - this is my limited experiance with the ones I came accross - there always are exceptions to every case
Reply With Quote
Sponsored Links


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

ECS on RSS ECS on Twitter ECS on Facebook ECS on Youtube
Follow us on:

Powered by vBulletin
Copyright 2002 - 2010, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.